Switching to Mirrorless, Part II

December 14, 2014  •  Leave a Comment
UPDATE
 
 
I think I damaged the LA-EA2 adapter; I'm not getting particularly sharp images with the Sony 70-400 or an old 400mm prime.  I'm also noticing the autofocus isn't quite as good as it is with the native "E" mount lenses.  I just sold all my "A" mount gear, and now I'm regretting it.  Don't get me wrong, I still love the a6000 and the FE 70-200mm F4 G OSS lens with it is a winning combo, if the animals are close enough.  I broke down and ordered a new a77 to use with the 70-400 (it was less than $600 at B&H).
 
I'm conflicted about doing this, as I really do prefer mirrorless.  I'm just waiting for Sony (or any lens maker) to make a native "E" mount 400mm or above.  Seriously, give me a 400mm f/4 and I'll be the happiest guy in the world!  Are you listening, Sony?
 
 

Comments

No comments posted.
Loading...

Archive
January February March April May June July August September October November December (1)
January (5) February March April May (1) June July (1) August September October November December (1)
January (2) February (1) March April (2) May June (1) July August September October (1) November December (1)
January February March (6) April (1) May (1) June July August September October November December
January February March April May June (1) July August September October November December
January February March April May June July August September October November December
January February March April May June July (1) August September October November December (1)
January February March April May June July August September October November December
January February March April May June July August September October November December
January February March April May (1) June July August September October November December